Jump to content

Cre8asiteforums Internet Marketing
and Conversion Web Design


Photo

Wordpress Install.php Giving White Screens


  • Please log in to reply
18 replies to this topic

#1 saschaeh

saschaeh

    Time Traveler Member

  • 1000 Post Club
  • 1026 posts

Posted 18 July 2008 - 06:38 AM

Im trying to install a fresh version of wordpress.

I uploaded everything created the DB connected and Im almost there. When it directs me to install.php it keeps giving me white screens. :search:

See white screen: http://www.inkind.co...min/install.php

Ive done a dozen installation in my life so im thinking its got something to do with the server (recently upgraded although other already installed blogs still work)


Iv changed some setting in php.ini (increased both php memory allocation and execution time) but it did not help.


Anyone had a similar issue?

#2 DonnaFontenot

DonnaFontenot

    Peacekeeper Administrator

  • Site Administrators
  • 3815 posts

Posted 18 July 2008 - 06:53 AM

Barry (bwelford) has this same issue (but with an upgrade). I spent a fair amount of time last night looking at his issue, and haven't yet come up with a definite fix for it, although I'm suspecting his cache plugin. Still, I'm not sure, especially now that you have this problem with a fresh install. So you obviously don't have any plugins yet.

Wondering if you and Barry have similar server setups now.

#3 bwelford

bwelford

    Peacekeeper Administrator

  • Site Administrators
  • 9011 posts

Posted 18 July 2008 - 07:50 AM

Thanks, Donna, for your efforts.

I still don't have any clear forward direction so I'm reverting to the website as it was since I have a complete FTPd version of the website and a database backup I made before starting the upgrade. I'll wait to get some clearer view on ll this before trying the upgrade again. The WordPress Codex Forums has messages from others who have had the same problem with the upgrade. There is as yet no clear answer there.

#4 eKstreme

eKstreme

    Hall of Fame

  • 1000 Post Club
  • 3399 posts

Posted 18 July 2008 - 07:55 AM

Guys, when you get a blank page, add the following line to the top of your .htaccess file:

php_value display_errors  "1"

Copy it exactly as is.

Upload the .htaccess and do a hard refresh (Ctrl-F5).

See if any error messages pop up.

Pierre

#5 bwelford

bwelford

    Peacekeeper Administrator

  • Site Administrators
  • 9011 posts

Posted 18 July 2008 - 08:16 AM

Following Donna's advice, I tried adding a php.ini file to do something similar but nothing changed.

I noticed some were getting a problem in the log file of the failed upgrade where there were two forward slashes // in the URL for a failed copy process in putting the site on Maintenance mode. In one iteration, I ran into the same problem. I think the WPAU may also be a little buggy.

#6 yannis

yannis

    Sonic Boom Member

  • 1000 Post Club
  • 1634 posts

Posted 18 July 2008 - 08:23 AM

http://www.inkind.co...min/install.php

GET /wp-admin/install.php HTTP/1.1
Host: www.inkind.co.za
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16
Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive

HTTP/1.x 500 Internal Server Error
Date: Fri, 18 Jul 2008 13:17:55 GMT
Server: Apache/2.2.3 (CentOS)
X-Powered-By: PHP/5.2.6
Content-Type: text/html
Content-Length: 0
Connection: Keep-Alive
----------------------------------------------------------

Well if we did't get a blank screen we would have completed the installation for you! :(
I do not think it is a php error but you probably have problems with permissions and directory structure!


Yannis

#7 saschaeh

saschaeh

    Time Traveler Member

  • 1000 Post Club
  • 1026 posts

Posted 18 July 2008 - 08:54 AM

php_value display_errors "1"

no errors pop up. Side note: When i give my htaccess file full permissions it disappears? That normal?


Well if we did't get a blank screen we would have completed the installation for you! biggrin.gif
I do not think it is a php error but you probably have problems with permissions and directory structure!


Ok so how would you suggest i go about checking permissions and folder structure?

PS: if you can install it please do! :(

I'm suspecting his cache plugin

Yes i do not have any plugins but:

1: Filezilla says fails to upload --> "wp-includes/js/tinymce/plugins/wordpress/js/" iv tried couple times no luck also i hace redownloaded WP still no luck.




Im busy making heads from this tread: http://wordpress.org...8447?replies=25



and then there is this: http://www.colinmcnu...creen-of-death/

#8 yannis

yannis

    Sonic Boom Member

  • 1000 Post Club
  • 1634 posts

Posted 18 July 2008 - 09:18 AM

If you got cpanel check the permissions of files. WP needs to write to the config file before completing the installation.

You can also try this.

In install.php write a couple of echo statements to see if the program is found.

echo 'I am here!';

Is this a new apache/php/mysql install? Is there a Fantastico panel?


Yannis

#9 saschaeh

saschaeh

    Time Traveler Member

  • 1000 Post Club
  • 1026 posts

Posted 18 July 2008 - 11:55 AM

Iv still had no luck... :(

Is this a new apache/php/mysql install? Is there a Fantastico panel?


well everything was upgraded and it is a Linux Plesk Virtuozzo.

echo 'I am here!';

Well i see 'I am here!'



In terms of htaccess. I have added php_value display_errors "1". but this has done nothing. Also when i change permissions of the htaccess file it disappears from the directory. Is this normal?


dazzlindonna - you had any luck?

#10 bwelford

bwelford

    Peacekeeper Administrator

  • Site Administrators
  • 9011 posts

Posted 18 July 2008 - 11:56 AM

I do not think it is a php error but you probably have problems with permissions and directory structure!

I think you're right, yannis. My hosting folder structure is weird to say the least. As I wandered around trying to get things to work, permissions were clearly not what they needed to be. The problem with WPAU is that it's a wonderful black box. If it works as it has in the past for me, it seems miraculous. When it doesn't, there's no easy tracking to pinpoint what may have happened although it does show you a log of tasks and results.

I'm now waiting to sort this out with my ISP. I did notice a funny situation with the site currently. I activated Live HTTP headers in Firefox and visited the site, http://www.staygolinks.com/ . This showed me a 200 result but the content size was 2399. If I check the same site with WebBug, using a HTTP 1.1 GET, then again it's a 200 result but the content size was 66899 and it seems to have the right code below that. Does anyone know WebBug and can explain how it can get what the normal visitor cannot get?

<afterthought>I do have the WP-SuperCache plugin operating normally so this might explain differences. However SiteMeter shows only 1 visitor so far today when normally there would be say 50 so far. That visitor was using Opera Mini. Can anyone else see the website using Opera?

Edited by bwelford, 18 July 2008 - 12:21 PM.


#11 yannis

yannis

    Sonic Boom Member

  • 1000 Post Club
  • 1634 posts

Posted 18 July 2008 - 01:34 PM

<?php
define('WP_INSTALLING', true);
if (!file_exists('../wp-config.php')) {
  require_once('../wp-includes/compat.php');
  require_once('../wp-includes/functions.php');
 [color=#FF0000]echo 'Config not found!!';[/color]
  [color=#FF0000]wp_die[/color]("There doesn't seem to be a <code>wp-config.php</code> file. I need this before we can get started. Need more help? <a href='http://codex.wordpress.org/Editing_wp-config.php'>We got it</a>. You can create a <code>wp-config.php</code> file through a web interface, but this doesn't work for all server setups. The safest way is to manually create the file.</p><p><a href='setup-config.php' class='button'>Create a Configuration File</a>", "WordPress &rsaquo; Error");
}

Yup! I can also see the I am here.

You will need to echo in different places in the script to see where the problem is. If it is internal there is a problem with wp-config.

With a lot of patience you can trace the problem.

Barry, I can see your website with normal Opera. Small changes in content length could be the result of advertisements being different or as you correctly pointed out caching.


Yannis

Edited by yannis, 18 July 2008 - 01:42 PM.


#12 bwelford

bwelford

    Peacekeeper Administrator

  • Site Administrators
  • 9011 posts

Posted 19 July 2008 - 10:46 AM

Just to update you on this problem, I have now reverted to WordPress version 2.5.1 for my blog until I resolve what happened with the Wordpress Automatic Upgrade plug-in (WPAU). From the log file of changes as recorded in the mySQL database, it would appear that the directory structure may be causing the plug-in to insert two '/' in URLs. This results in URLs like this:
/home/virtual/site143/fst/var/www/html//wpau-backup/wpau-files-bak.zip
This then causes errors in subsequent file copying.

I have raised this in the WPAU Support Forum. Perhaps that will give us the answer.

#13 saschaeh

saschaeh

    Time Traveler Member

  • 1000 Post Club
  • 1026 posts

Posted 19 July 2008 - 06:50 PM

Well i fixed my WP issue like this:

I managed to show the execution errors and it told me on line 6 there was an syntax error:

So what was it?


Incorrect:
define('DB_PASSWORD', 'mypassword')
define('DB_HOST', 'localhost');


Corrected
define('DB_PASSWORD', 'mypassword') ;
define('DB_HOST', 'localhost');


Can you believe they released it with syntax errors like that!?

Edited by saschaeh, 19 July 2008 - 06:51 PM.


#14 bwelford

bwelford

    Peacekeeper Administrator

  • Site Administrators
  • 9011 posts

Posted 19 July 2008 - 08:13 PM

That's certainly surprising, saschaeh. Which file was that code from?

#15 saschaeh

saschaeh

    Time Traveler Member

  • 1000 Post Club
  • 1026 posts

Posted 19 July 2008 - 09:00 PM

Now I was intending to included that!

config.php

#16 DonnaFontenot

DonnaFontenot

    Peacekeeper Administrator

  • Site Administrators
  • 3815 posts

Posted 19 July 2008 - 09:33 PM

wow, barry, would be interesting to see if that was also your problem. if so, then it wasn't wpau's fault at all, as i suspected.

#17 bwelford

bwelford

    Peacekeeper Administrator

  • Site Administrators
  • 9011 posts

Posted 19 July 2008 - 09:49 PM

I guess you mean wp-config.php, saschaeh. Wordpress only supplies wp-config-sample.php, which you then amend in a first time installation to create your own wp-config.php. That file should remain unchanged from the previous version you had. The code for the sample starts off as follows, which seems to be correct.
<?php
// ** MySQL settings ** //
define('DB_NAME', 'putyourdbnamehere');	// The name of the database
define('DB_USER', 'usernamehere');	 // Your MySQL username
define('DB_PASSWORD', 'yourpasswordhere'); // ...and password
define('DB_HOST', 'localhost');	// 99% chance you won't need to change this value
define('DB_CHARSET', 'utf8');
define('DB_COLLATE', '');
That doesn't seem to be my problem, so I'm still trying to understand.

#18 saschaeh

saschaeh

    Time Traveler Member

  • 1000 Post Club
  • 1026 posts

Posted 20 July 2008 - 03:16 AM

I guess you mean wp-config.php, saschaeh



Yes but i did just rename there sample-wp-config.php to wp-config.php and added my DB details. I downloaded & installed WP twice (i think maybe even 3rd time on different domain) and all times it gave me these white screens.

Strang thing that we all having similar issue but not the same solution...

#19 bwelford

bwelford

    Peacekeeper Administrator

  • Site Administrators
  • 9011 posts

Posted 20 July 2008 - 12:15 PM

On this topic, GetFoundNow has two useful posts:In the second, s/he mentions that you may need to clear cookies before going to the Admin Panel, if you've had a white screen problem.



RSS Feed

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users