Jump to content

Cre8asiteforums Internet Marketing
and Conversion Web Design


Photo

Latest Wordpress Post Not Showing On Blog Home


  • Please log in to reply
24 replies to this topic

#1 tommr

tommr

    Light Speed Member

  • 500 Posts Club
  • 578 posts

Posted 10 August 2011 - 06:11 PM

I just posted a new article on my word press blog but the article does not appear as the landing page default.

The blog is set so that the most recent post is suppose to show up on top.

I changed nothing and the blog is up to date as are all the plugins.

It figures that just as I get a good motivated writer something goes goofy.

Any help would be appreciated.

#2 Michael_Martinez

Michael_Martinez

    Time Traveler Member

  • 1000 Post Club
  • 1354 posts

Posted 10 August 2011 - 07:19 PM

Has it been a while since you last published something on the blog? If so, you're probably fine. Your SERPs will become more fresh as you go along publishing new content at a rapid clip.

At least, this is how I've seen it work for my own blogs over the last year or so. Any break in publication seems to reduce the crawl rate for the site. Any uptick in publishing rate seems to result in improved crawl rate.

#3 bwelford

bwelford

    Peacekeeper Administrator

  • Admin - Top Level
  • 8995 posts

Posted 10 August 2011 - 07:57 PM

Hi Tommr,

I was thinking your post concerns the Wordpress mechanisms rather than ranking in search engines.

I assume you have set the number of posts to appear on the Home Page as 1 or more and show the posts in their entirety.

The only thing I can think is that perhaps somehow the new post has had its date of publication edited so that the date is prior to the previous most recent post. In that case the new post will not show at the top of the Home Page.

HTH

#4 DonnaFontenot

DonnaFontenot

    Peacekeeper Administrator

  • Admin - Top Level
  • 3716 posts

Posted 10 August 2011 - 09:17 PM

Or perhaps the post has been assigned to a category that you've excluded from showing up sometime in the past.

#5 tommr

tommr

    Light Speed Member

  • 500 Posts Club
  • 578 posts

Posted 10 August 2011 - 09:17 PM

The date is after the previous date and I have done several test posts. The previous post seems to end up on top every time.


I have to dig further.

#6 tommr

tommr

    Light Speed Member

  • 500 Posts Club
  • 578 posts

Posted 10 August 2011 - 09:28 PM

I deleted all the categories and have tried to post and the new posts do not go on top. grrrrrrr

#7 AbleReach

AbleReach

    Peacekeeper Administrator

  • Admin - Top Level
  • 6457 posts

Posted 10 August 2011 - 11:22 PM

This is your site, not your site's SERPs, right?

Something may have been accidentally changed. I'd start with the big stuff first, one at a time.

If you have ever played in mysql or htaccess, take a peek there now and see if something rings a bell. If not, it's got something to do with your theme or your installation of WordPress.

Rule out your theme. Try a different theme. If you have the same problem, it's down to your installation of WordPress.

Rule out a problem with your WordPress installation - seems unlikely to me. Re-install WordPress. If that didn't change things, it's a plugins or settings thing.

Rule out plugins. Uninstall all plugins, on the off chance there was a conflict or some special setting there - seems unlikely.

In the back end, go to the top of a Posts or Page and make all screen options visible. Look at individual posts - are any of them set to be "sticky"?

That's all I can think of at the moment. At least, this should help you rule some things out.

In one of my blogs the "must be registered and logged in to comment" box was checked. I don't remember doing that and wouldn't have believed it if a very persistent reader hadn't sent me a screenshot. Thanks to her, it's now set to let comments flow again. I was wondering where reader response had gone, but it's always been light for that blog, so I hadn't wondered with much focused attention!

#8 tommr

tommr

    Light Speed Member

  • 500 Posts Club
  • 578 posts

Posted 11 August 2011 - 08:50 AM

Thanks for all the suggestions.
I have tried most every thing and still the posts are out of order.

I can not find out if posts are sticky. I looked under the screen options and I do not see that option.

Also, a few other strange things are showing up.

1. Even though I have the blog set to display 10 pages it only displays 1 on the front. If I click the category it displays 10 but the front only shows 1.

2. When I preview a theme it shows the new post as the front page but if I change themes the previous post shows as the front page. Again with the switched theme if I view my default theme the newest post shows but when I switch back the older post shows as the front page.

Its almost like there is some goofy redirect.

#9 tommr

tommr

    Light Speed Member

  • 500 Posts Club
  • 578 posts

Posted 11 August 2011 - 08:57 AM

Found the sticky option and it was not checked.

#10 jonbey

jonbey

    Eyes Like Hawk Moderator

  • Moderators
  • 4294 posts

Posted 11 August 2011 - 10:48 AM

Probably obvious suggestions, but, maybe a browser cache problem?
Or a strange, broken Wordpress cache problem?

if you PM the website i would be happy to double check your latest post is not there.

#11 iamlost

iamlost

    The Wind Master

  • Admin - Top Level
  • 4457 posts

Posted 11 August 2011 - 11:03 AM

I am presuming that we are discussing the site in your profile?
If so when I go to site and click nav link for blog [http://www.theweddin.../wedding-blog/] I see an immediate 301 to
[http://www.theweddin...r-the-big-day/]

When I then click 'Wedding Blog Home' text link I get the same redirect.

#12 jonbey

jonbey

    Eyes Like Hawk Moderator

  • Moderators
  • 4294 posts

Posted 11 August 2011 - 11:08 AM

Weird.

Is "Welcoming fall with a theme wedding" the new one? I can see that in the August archive.

#13 bwelford

bwelford

    Peacekeeper Administrator

  • Admin - Top Level
  • 8995 posts

Posted 11 August 2011 - 11:24 AM

Your comment, iamlost, might suggest that the blog is using the LMNHP approach. That would not explain the non-appearance of the most recent post. However as I note in another topic, I no longer find a need to use that approach.

#14 tommr

tommr

    Light Speed Member

  • 500 Posts Club
  • 578 posts

Posted 11 August 2011 - 11:25 AM

Yes the fall one is the most recent and I do not know where this redirect is originating.
I am using a plugin called Redirection that is suppose to manage 301 redirects.
I am also using Disable Canonical URL Redirection, and Permalink Redirect that is suppose to clean up the end of the urls.
The blog has been working ok until this most recent post. I tried disabling the plugins but I still get the wrong page.

I think I will try disabling them one at a time and post a test to see what happens.

#15 tommr

tommr

    Light Speed Member

  • 500 Posts Club
  • 578 posts

Posted 11 August 2011 - 11:34 AM

And that did not work. I wonder why and how there could be a 310 redirect on just this one post.
I hate to delete it to test as it has been crawled.

#16 DonnaFontenot

DonnaFontenot

    Peacekeeper Administrator

  • Admin - Top Level
  • 3716 posts

Posted 11 August 2011 - 11:57 AM

Sounds like it's definitely theme related, since switching themes shows it properly. Does the theme have an options panel? If so, scour it for any hints. If not, you may need to dig into the theme code itself to see what might be going on.

Might be some kind of conflict too. I'd probably disable all plugins and see if that helps, and if so, enable one at a time.

#17 tommr

tommr

    Light Speed Member

  • 500 Posts Club
  • 578 posts

Posted 11 August 2011 - 12:30 PM

Different themes do not make a difference. Only when I preview a theme does the correct post show. I changed the theme and posted a test and it does not show up.

There is some funky redirect going on.

#18 DonnaFontenot

DonnaFontenot

    Peacekeeper Administrator

  • Admin - Top Level
  • 3716 posts

Posted 11 August 2011 - 01:47 PM

Ah I misunderstood then, sorry.

If it's not a plugin that's causing the issue, then you may need to start completely fresh with a new install of WP.

#19 Michael_Martinez

Michael_Martinez

    Time Traveler Member

  • 1000 Post Club
  • 1354 posts

Posted 11 August 2011 - 02:16 PM

Boy did I misread the problem in this discussion. :frustration:

#20 jonbey

jonbey

    Eyes Like Hawk Moderator

  • Moderators
  • 4294 posts

Posted 11 August 2011 - 06:08 PM

How does the redirect plugin work? Are you sure the just disabling it removes the redirects? Maybe it writes to htaccess but for some reason (sloppy design etc) it does not remove the redirects if you deactivate / remove it. Just guessing.

#21 tommr

tommr

    Light Speed Member

  • 500 Posts Club
  • 578 posts

Posted 11 August 2011 - 06:20 PM

This is the only .htaccess file I can find anywhere in the blog directory.
I have no idea how the redirect works but there is java script files in the directory.

I disabled the plugins and did test posts and the same post comes up on top. It's weird because when I preview any theme the correct post shows up.

#22 AbleReach

AbleReach

    Peacekeeper Administrator

  • Admin - Top Level
  • 6457 posts

Posted 11 August 2011 - 08:18 PM

Try re-setting what WordPress uses as the home page for both your root domain and your blog.

First, disable any plugins, just to be sure.

Then, go to Settings > Reading and change every single option in there to something different. Save, refresh the browser, check to see if it took.

Then go back and change them to what you want.

#23 tommr

tommr

    Light Speed Member

  • 500 Posts Club
  • 578 posts

Posted 11 August 2011 - 09:48 PM

OK Now we are getting somewhere!!!

I tried turning off the plug ins before but I did not reset the landing page. This seems to be the ticket!

I changed the landing page and then I viewed it with another browser. Firefox was not clearing the page but IE did. So I could see the changes.

Once it was working I re installed the plugins and viewed it with the other browser. Sure enough it was back to the old problem.

I disabled all the plugins, and re set the pages, then changed it back to the latest post and everything seems fine.

I re enabled just a few plugins, any not having anything what so ever to do with redirect and it is still working fine.

I will be able to weed the offending plug in out by trial and error but for now I am leaving it as is. This is enough for one day.

WHEW.

Thank you everyone for the help and input.

#24 AbleReach

AbleReach

    Peacekeeper Administrator

  • Admin - Top Level
  • 6457 posts

Posted 11 August 2011 - 11:31 PM

Here's one answer: FireFox can need a page to be reloaded a few times before changes show up. Stubborn cache.

So glad you're getting to the bottom of this!

#25 tommr

tommr

    Light Speed Member

  • 500 Posts Club
  • 578 posts

Posted 12 August 2011 - 07:34 AM

FireFox also seems to choke on gmail scripts, but I still use it.

Thanks for figuring this problem out!



RSS Feed

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users