Jump to content

Cre8asiteforums

Web Site Design, Usability, SEO & Marketing Discussion and Support

  • Announcements

    • cre8pc

      20 Years! Cre8asiteforums 1998 - 2018   01/18/2018

      Cre8asiteforums In Its 20th Year In case you didn't know, Internet Marketing Ninjas released many of the online forums they had acquired, such as WebmasterWorld, SEOChat, several DevShed properties and these forums back to their founders. You will notice a new user interface for Cre8asiteforums, the software was upgraded, and it was moved to a new server.  Founder, Kim Krause Berg, who was retained as forums Admin when the forums were sold, is the hotel manager here, with the help of long-time member, "iamlost" as backup. Kim is shouldering the expenses of keeping the place going, so if you have any inclination towards making a donation or putting up a banner, she is most appreciative of your financial support. 
Sign in to follow this  
bwelford

Problem Uploading Images In Wordpress

Recommended Posts

I am somewhat baffled by the fact that one of my WordPress blogs (exactly the same as my other WP blogs as far as I know) will no longer allow me to upload images. I get the following error message.

 

“abcdef.jpg” has failed to upload due to an error

Unable to create directory /home/bwelford/public_html/seniormoneymemos.com/wp-content/uploads/2011/11. Is its parent directory writable by the server?

 

As I said, I have other 'parallel' WP blogs that have not given me this problem and I don't believe I've had problems in the past with this one.

 

Does anyone have suggestions on where to look for answers.

Share this post


Link to post
Share on other sites

Yep, the answer is right there in the error message. The folder isn't writable. For whatever reasons, the folder no longer has the correct permissions set. Go set the permissions via ftp on wp-content so that it's writable, and it should be all good.

Share this post


Link to post
Share on other sites

May not just be permissions. Could be PHP security set too high. I had this problem is Plesk. Somewhere I turned off PHP Safe Mode.

I changed something in the admin control panel but searching Google shows some php.ini modifications to turn it off.

 

Give that a whirl.

Share this post


Link to post
Share on other sites

That's why I'm scratching my head. The permissions for those folders are 0755 so it should be OK. Somehow I think it believes I am not the owner, so I'm going to have to found out why this does not behave like the other four. It's not a priority today, but just something else to add to the pile. :(

Share this post


Link to post
Share on other sites

Mine was the same, permissions were correct, it was the server blocking the PHP file transfer.

Share this post


Link to post
Share on other sites

I'd probably put in a support request with the host then. They can probably tell you pretty quickly what the issue is.

Share this post


Link to post
Share on other sites

I once saw that error while uploading an image that was larger than the limits I had set for my blog. I think it's kind of a ubiquitous warning (or perhaps a bug in the warning system -- I've upgraded Worpress a few times since then).

Share this post


Link to post
Share on other sites

If you have not checked the PHP Safe Mode settings, this seems to be the way there in cpanel:

 

1. Login to WHM.

 

2. Go into the Service Configuration menu and locate the PHP Configuration Editor.

3. From there you can set the various PHP settings such as disabling SAFE MODE.

Share this post


Link to post
Share on other sites

Things i would checked:

 

If this WP site was restored from a backup Apache sometimes sets the owner to Apache, so you need to contact the host and ask them to reset ownership permissions.

 

Can you confirm to yourself that the permission setting has actually been set? IE CHMOD the uploads folder to 755 and then check the CHMOD setting by sending the command again (in something like Filezilla you will get a popup to set the comands and it will show to what the folder is curently set to), sometimes you can send the CHMOD change command but in fact it doesn't set it (for reasons as described above), I know I've missed this in the past.

 

Try changing the permission of the uploads folder to 775, and see if that works. If it does, send a message to your host and ask them why 755 won't work, if it does on other sites hosted on the same server.

 

I also saw this

"Just create /tmp folder in your wordpress directory and it should be fine - works for me :-)"

Source: http://wordpress.org/support/topic/27-image-upload-not-working

 

Good luck

Share this post


Link to post
Share on other sites

Donna you were right. I had not realized that I had to make a change when my server arrangement was changed. Somehow the others had been changed but this one was not. My host is in the process of correcting this.

 

Thanks to all for suggestions. As Einstein said, it's usually best to go for the simplest answer that works, but it should not be simpler than that.

Edited by bwelford

Share this post


Link to post
Share on other sites

Glad it got figured out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×